Automatic summarization in RIP and EIGRP


Summarization in RIP and EIGRP can be configured manually using the ip summary-address command or automatically using auto-summary command. when auto summarization is in effect routers behave as shown in the steps below:

  • Subnets are summarized to their classful boundary before being sent to neighbors if they are not part of the major subnet of the exit interface.
  • EIGRP automatically installs a discard route in the local routing table. RIP does not install a discard route by default.

In the following example we will explore EIGRP with automatic summarization enabled:

Router1 is connected to Router2 by a serial link and each router has loopback interfaces configured as shown in following diagram

Summarizaiton
Router1 Configuration (same configuration applies to Router2)

R1(config)#router eigrp 10
R1(config-router)#auto-summary
R1(config-router)#network 131.108.0.0
R1(config-router)#network 137.99.0.0

Router1 routing table:

R1(config-router)#do sh ip route eigrp
137.99.0.0/16 is variably subnetted, 2 subnets, 2 masks
D 137.99.0.0/16 is a summary, 00:04:54, Null0 <– discard route
131.108.0.0/16 is variably subnetted, 4 subnets, 2 masks
D 131.108.3.0/24 [90/2297856] via 131.108.2.2, 00:06:00, Serial1/0 <– was not summarized
D 131.108.0.0/16 is a summary, 00:05:15, Null0 <– discard route

Router2 routing table:

R2(config-router)#do sh ip route eigrp
D 137.99.0.0/16 [90/2297856] via 131.108.2.1, 00:05:29, Serial1/0 <– Summarized subnet
131.108.0.0/24 is subnetted, 3 subnets
D 131.108.5.0 [90/2297856] via 131.108.2.1, 00:05:50, Serial1/0 <– non summarized route

Automatic summarization summarized:

  • R1 installs discard routes pointing to null interface before sending summaries.
  • R1 sends the summarized route 137.99.0.0/16 to R2.
  • R1 sends 131.108.5.0/24 un-summarized because its part of the major subnet of the its exit interface.


No related posts.


You can follow any responses to this entry through the RSS 2.0 feed. You can leave a response, or trackback from your own site.

AddThis Social Bookmark Button

2 Responses to “Automatic summarization in RIP and EIGRP”

  1. save to my Bookmarks :)

  2. Mohamed Kamal Says:

    Dear Wael,

    Sorry if the question isn’t related to EIGRP summerization. But it’s, generally speaking, about EIGRP.

    I know that we can advertise default routes into an EIGRP domain by any of the following:

    1- Static default router and redistributes it under the EIGRP process.
    2- Using the IP default-network.

    I’ve tried the first option and it worked, everything is alright regardless of the AD of 170! But when I tried the IP default-network command, I reached the following:

    R1#sh run

    interface Loopback0
    ip address 1.1.1.1 255.255.255.0
    !
    interface Serial0/0
    ip address 172.12.123.1 255.255.255.0
    encapsulation frame-relay
    frame-relay interface-dlci 102
    frame-relay interface-dlci 103
    !
    interface Serial0/1
    ip address 10.1.1.1 255.255.255.0
    !
    router eigrp 1
    network 1.1.1.0 0.0.0.255
    network 10.1.1.0 0.0.0.255
    network 172.12.123.0 0.0.0.255
    no auto-summary
    !
    ip http server
    ip classless
    ip default-network 10.0.0.0

    R1#sh ip route

    Gateway of last resort is not set

    1.0.0.0/24 is subnetted, 1 subnets
    C 1.1.1.0 is directly connected, Loopback0
    2.0.0.0/24 is subnetted, 1 subnets
    D 2.2.2.0 [90/2297856] via 172.12.123.2, 00:26:41, Serial0/0
    3.0.0.0/24 is subnetted, 1 subnets
    D 3.3.3.0 [90/2297856] via 172.12.123.3, 00:26:41, Serial0/0
    4.0.0.0/24 is subnetted, 1 subnets
    D 4.4.4.0 [90/2300416] via 172.12.123.3, 00:26:41, Serial0/0
    [90/2300416] via 172.12.123.2, 00:26:41, Serial0/0
    5.0.0.0/24 is subnetted, 1 subnets
    D 5.5.5.0 [90/2297856] via 10.1.1.5, 00:00:52, Serial0/1
    172.12.0.0/24 is subnetted, 2 subnets
    D 172.12.34.0 [90/2172416] via 172.12.123.3, 00:26:41, Serial0/0
    [90/2172416] via 172.12.123.2, 00:26:41, Serial0/0
    C 172.12.123.0 is directly connected, Serial0/0
    * 10.0.0.0/24 is subnetted, 1 subnets
    C 10.1.1.0 is directly connected, Serial0/1

    Notice that there is no “ip route” statement created and also there is no route marked as candidate default!

    So what is the problem?

    - will I have to adjust the prefix of the network 10.0.0.0/24 at the interface to be /8 for the EIGRP to know about and then use it as a default network? .. I guess not!

    - will I have to adjust the network command under the EIGRP to include the /8 prefix network instead of /24 prefix and then EIGRP will now know about the network and use it with ip default-network? .. I guess not!

    NOTE: I hope that you can write a post about IGPs and Candidate Default Routes! especially using the ip default-network as they are tend to be confusing.

    Thanks in advance.

Leave a Reply