How-to: Configure Frame-relay Switching

Routers can be configured as Frame Relay switches to be used mostly in service provider or LAB environments. Lets see how you can configure frame-relay switch to use your in studies.

On a Frame Relay switch, frames from a Frame Relay PVC arriving o­n an incoming interface are switched to a Frame Relay PVC o­n an outgoing interface. The switching paths taken by the frames are based o­n the static Frame Relay route table.

In the following example two routers (Router1 & Router2) are connected via a router acting as a dedicated frame-relay switch (FRSW) .

FRSW

Configuration steps:

  • Enable frame relay switching o­n FRSW using the global command frame-relay switching.
  • Configure the frame-relay switch interfaces to act as a DCE interface using the command frame-relay intf-type.
  • Configure a frame relay PVC o­n FRSW to switch packets coming from DLCI 100 o­n Serial1/0 to DLCI 200 o­n Serial1/1.
  • Configure typical frame relay o­n both routers (Router1 & Router2).
  • Verify and check the operation.

Frame-relay switch configuration:

FRSW(config)#frame-relay switching
FRSW(config)#interface s1/0
FRSW(config-if)#description Connection to Router1
FRSW(config-if)#encapsulation frame-relay
FRSW(config-if)#frame-relay intf-type dce !–act as a switch connected to router

!–specify a static route PVC switching.
FRSW(config-if)#frame-relay route 100 interface serial 1/1 200
FRSW(config-if)#clock-rate 128000

FRSW(config-if)#interface s1/1
FRSW(config-if)#description Connection to Router1
FRSW(config-if)#encapsulation frame-relay
FRSW(config-if)#frame-relay intf-type dce
FRSW(config-if)#frame-relay route 200 interface s1/0 100
FRSW(config-if)#clock-rate 128000

Router1 & Router2 configuration:

This is a basic frame relay configuration using main serial interfaces and all defaults.

Router1(config)#int s1/0
Router1(config-if)#encap frame-relay
Router1(config-if)#ip address 12.12.12.1 255.255.255.0
Router1(config-if)#no shut

Router2(config)#int s1/0
Router2(config-if)#encap frame-relay
Router2(config-if)#ip address 12.12.12.2 255.255.255.0
Router2(config-if)#no shut

Verification and troubleshooting:

The following show commands were taken from the frame relay switch “FRSW” and Router1

FRSW#sh frame-relay route
Input Intf Input Dlci Output Intf Output Dlci Status
Serial1/0 100 Serial1/1 200 active
Serial1/1 200 Serial1/0 100 active

FRSW#sh frame-relay pvc | in DLCI
DLCI = 100, DLCI USAGE = SWITCHED, PVC STATUS = ACTIVE, INTERFACE = Serial1/0
DLCI = 200, DLCI USAGE = SWITCHED, PVC STATUS = ACTIVE, INTERFACE = Serial1/1

Verification from Router1 point of view “same is done o­n Router2″

Router1#ping 12.12.12.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 12.12.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/60/132 ms

Router1#show frame-relay map
Serial1/0 (up): ip 12.12.12.2 dlci 100(0×64,0×1840), dynamic,
broadcast,, status defined, active

Note: L2 to L3 resolution is accomplished dynamically using inverse arp.


No related posts.


You can follow any responses to this entry through the RSS 2.0 feed. You can leave a response, or trackback from your own site.

AddThis Social Bookmark Button

Leave a Reply